Firefox 2.0 and Internet Explorer 7

The two most popular web browsers were recently updated: Firefox 2.0 and Internet Explorer 7. I’d advise downloading and installing either of them for greater security, faster response and more convenience.

My web stats for October indicate that 62% of the users of lesliewong.us use IE6 and 17% use Firefox 1.5.0.7. Please update your software. If you need help, let me know.

Unfortunately, IE7 can only be installed on Windows XP Service Pack 2 systems (plus XP Pro x64 and three Windows Server 2003 editions), so if you’re using Windows 98, Windows NT or Windows 2000, you’re SOL (1) with Internet Explorer.

Firefox 2.0 will run on Windows operating systems (Windows 98, 98SE, ME, NT (2), 2000, XP, Server 2003), Macintosh (G3 or later and OS X 10.2.x or later), and Linux (at least Kernel 2.2.14).

You can find Firefox in other languages and builds for uncommon platforms, e.g., PowerPC Linux. Internet Explorer 7.0 is available in Finnish, German, Japanese, and Spanish and Release Candidates for other languages.

(1) SOL in this case does not refer to any of these definitions

(2) The Windows installer will not work on Windows NT 4.0 without version 5.80 of the Comctl32.dll library installed

Leave a Reply