Windows 7 Performance on Legacy Systems

Windows Experience Index on a Via pc2500I installed the Windows 7 Beta (7000) on my Via pc2500, powered by a 1.5 GHz Via C7-D, an x86-compatible desktop processor. The Via motherboard is installed in a SilverStone SST-LC11S-300 HTPC case connected to a Sony KV-36FV1 television.

I wanted to use the Via pc2500 as a DVD player and Netflix streaming player but the performance of Windows 7 Beta on the Via pc2500 isn’t really that great, even with a PCI video card (a EVGA 256-P1-N399-LX GeForce 6200 256MB 64-bit GDDR2). With 2GB of system RAM and the latest version of Silverlight, Netflix streaming is jerky. DVDs played with Windows Media Player also do not play smoothly.

The Windows Experience Index was only 1.3, and the blame was on the Via 1.5 GHz processor. Task Manager showed 100% CPU usage while trying to stream Netflix. (My ATT-Yahoo DSL connection (Elite 6.0/768) speed is about 5.2 mb/s down and 437 kb/s up, so Netflix streaming looks OK on my more robust PCs.) I don’t really see how the new netbooks can have any decent performance with Windows 7.

The pc2500 is currently my hardware looking for an applicaton. Now I’ve tried Windows XP, gOS, Ubuntu, Windows Vista, Windows 7 and Linux MCE. The Via hardware is just anemic. Maybe with a Mimo USB monitor, it’d be OK as a carputer.

Windows Experience Index on a Shuttle SB51G

Windows 7 Beta on my vintage (purchased 2002) Shuttle SB51G works OK. The Shuttle XPC has an Intel Pentium 4 2.8GHz CPU (SL6HL), 1 GB RAM and an ATI All-In-Wonder 9600. I normally boot Windows XP 2005 MCE and use it as a file server, media server (using TVersity), DVD player and Netflix streaming client (through a browser).

Windows 7 performance feels comparable to XP MCE, that is to say, it doesn’t feel slow. But there also isn’t any other crap installed – anti-virus and other applications. The Windows Experience Index was 3.0, and in this case, the sluggard was the Seagate Barracuda 7200.10 Ultra ATA/100 320 GB hard drive.

Since there are no Windows 7 video drivers for the lowly ATI Radeon 9600 / X1050, I used the ATI Catalyst 9.1 Display Driver for Windows Vista. I wanted to use ATI Catalyst Control Center application to hotkey switch between the primary and secondary display (Dell 2007 WFP and a Sony KV-36FV1), so I can watch DVDs on the Sony TV in the living room. The hotkey switch that works in XP doesn’t work with Windows 7.